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Introduction

This document will introduce you to the inDEED visualization and analysis tool. In order to use this tool,
you will need data files that are in a CSV (comma delimited) format and the *.ind file for your
instrumentation, which is created by the Specimen Authoring Tool. The data files need to be in the same
directory in the workspace as the *.ind file (Figure 1).

|_1Ports-Grand-Challenge g@
File Edit Wew Favorites Tools  Help ﬁ'
O Back - () ir 7/ ) Search Folders Elv
#fddress ([ https:f{neeshub.org/webdav/Ports-Grand-Challenge hd a Go

Mame Internet Address Size | Type

Folder Tasks &3 [ documents https:}/neeshub.orgfwebdaw/Ports-Grand-C. .. ‘Web Folder 3
3 e e e hes @ncclocsp.png https: j fneeshub.orgfwebdayPorts-Grand-C... Z5.9KE PNGFile 3
. E_Ii]ncclocsx.png https: j fneeshub.orgfwebdayPorts-Grand-C... Z6.6 KB PNGFile 3

D Epry Ui =etizal iz @crossZ.PNG https: j fneeshub.orgfwebdayPorts-Grand-C... .17 KB PNGFile 3
2 Delete the selected items EFLPiocsp.png https: f ineeshub.orgfwebdayPorks-Grand-C... 28.4KE  PMNG File 3
@ Parts Grand Challenge_Sumrnary kxk https: j fmeeshub.argfwebday/Paorts-Grand-C... S.0KE Text Document 3

Other p . x @PPTIocsp.png https:}/meeshub, orgfwebday/Ports-Grand-C... 32,1KB PNGFile 3
@PPTIocsx.png https:}/neeshub,orgfwebday/Ports-Grand-C... 27.4 KB PNGFile 3

[ MEESHub | https: /neeshub,argfwebday/Ports-Grand-C... 322KB IND File 3
(5} My Documents |=‘] wired_PACOL.prt https: /neeshub,argfwebday/Ports-Grand-C... 16,7 ME PRT File 3
3 shared Documents |=‘] wired_PACOZ.prt https: /neeshub.argfwebday/Ports-Grand-C... 20.0ME  PRT File 3
|'>‘] wired_PACOS.prt https: }fneeshub.argfwebday/Ports-Grand-cC... 19.6ME  PRT File 3

‘3 My Metwork Places |=‘] wired_PACO4.prt https: }fneeshub.argfwebday/Ports-Grand-cC... 31.Z2ME PRT File 3
|'s‘] wired_P3LO1.prt https: / fneeshub.argfwebday/Ports-Grand-cC... Z0.3ME PRT File 3

|'s‘] wired_PSLOZ.prt https: j fneeshub.orgfwebdayPorts-Grand-C... 20,1 MB PRT File 3

|'s‘] wired_P3LO3.prt https: j fneeshub.orgfwebdayPorts-Grand-C... 33.ZME PRT File 3

ljwired_PSLD‘%.csv https: j fneeshub.orgfwebdayPorts-Grand-C... 33.0MB  Microsoft Office Exc... 3]

|'= wired_SINOL.prt https: j fmeeshub.argfwebday/Paorts-Grand-C... 20.8MB  PRT Filz 3

< >

Figure 1: Data files and *.ind file in the same directory in the NEESHub workspace
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1.0 Loading Data
(File -> Open -> *.csv file)
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Launch inDeed. From the “File” menu, choose “Open”, and browse to your comma delimited data file
(Figure 2). The tool will automatically locate the *.ind file and load it so that all of the instruments,
groups, specimen views, and notes made in the Authoring Tool are now available along with the data
from the selected data file (Figure 3).
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Figure 2: Loading a data file

£/ NEEShub

[File Edit view Pt

Name

g TIME

E]--&‘ PPT-Drains
@- g PPT-Untreated
El-g%% PPT-Tubes

) &: ACC-Drains
B¢y ACC-Untreated
@-¢ ACC-Tubes
- %Y Disp-Drains
E]--&: Disp-Unireated
E]--&‘ Disp-Tubes
@-gQ PPT-AI

B g% ACC-Al

) &‘ Disp-All
B¢ ACC-Container
E]--&% Uncategorized

Find sensors

Uncalegarized Tine

name |

@ @ @@

bt Piot

&

Figure 3: inDEED automatically loads the *.ind file
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2.0 Viewing the Instruments

The instrument list and specimen views are loaded from the *.ind file. The instrument list is in the left
panel and the specimen views appear in the storyboard panel. Selected specimen views will appear in
the large area in the bottom right. Multiple specimen views can be open simultaneously and each will
have its own tab (Figure 4). The instrument list panel can be widened or narrowed by grabbing the right
panel frame and dragging it (a double arrow <> will appear when your mouse is in the right spot). Below
the instrument list is a search text box that can be used to search for a particular instrument. Below the
search text box are the instrument type buttons, which are all selected by default. Deselecting a type
button will remove all instruments of that type from the instrument list.

The “View” menu contains the options for viewing the instruments and for selecting which tool panels
are displayed (Figure 5). “Tree View” sorts the instruments by group while the “List View” does not. If
you choose to sort the instruments based on name, type, etc. , the tool will automatically switch to list
view (Figure 6). “Show Storyboard” displays / hides the storyboard panel. “Show Sensor List”
displays/hides the instrument list. “Expand Groups” expands all of the groups so that the individual
instruments are displayed and “Collapse Groups” hides the individual instruments and displays only the
group names. Groups may also be collapsed/expanded in tree view by clicking on the - / + next to the
group name. The remaining options (“Sensor Type”, “Measurement Type”, Measurement Units”,
“Sensor Direction” and “Sensor Description”) may be selected / deselected to show / hide additional
sensor information.
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Figure 4: Viewing the instruments
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Figure 5: The "View" menu
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Figure 6: Tree view (left) and List view (right) sorted by name

PURDUE UNIVERSITY
-

Discavery Park




‘ | comm

NEES . o
NEEShub.org — Getting started with inDEED

3.0 Selecting Instruments
Selecting the instruments whose data you want to plot can be done either from the specimen views or
from the instrument list. If you select more than one instrument type, e.g., pore pressure transducers
and accelerometers, which instruments get plotted will depend on the type of plot that you create.

3.1 Selecting Instruments from the Specimen View
Select a specimen view by clicking on it in the storyboard bar at the top of the tool. Then, select
instruments by double clicking them in the large specimen view. When an instrument is selected, a red

checkmark will appear on the instrument marker (Figure 8). You can unselect a marked instrument by
double clicking it again.

Additional notes:
You may select instruments from multiple specimen views.

If you hover the mouse over the instrument a text box will appear with the instrument name and type
(Figure 9).
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Figure 7: Selected instruments with red check mark on the instrument marker
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Figure 8: Text box with instrument name and type

3.2 Selecting Instruments from the Instrument List

There are several ways to select instruments from the instrument list. The first way is to click the column
to the left of the instrument. A red check will appear indicating that the instrument has been selected
for plotting (Figure 10). To deselect the instrument, click the red check and it will disappear.

You can highlight several instruments by highlighting the first instrument, holding down the shift key,
and then clicking on the last instrument you want to highlight. You can also hold down the control key
and highlight multiple instruments by clicking on them individually. Once you have multiple instruments
selected you can select them by right clicking with the mouse and choosing “select” from the menu
(Figure 11). From this menu, you can also deselect instruments or toggle the instrument status, meaning
that an instrument that was selected will be deselected and an instrument that was not selected will be
selected (Figure 12). The right-click menu options also work for single instruments, not just selections of
multiple instruments.

In the right-click menu there are also “Select All” and “Select None” options. The “Select All” option will
select all instruments (not just highlighted instruments), and the “Select None” option will deselect all

instruments (Figure 13).

The same options available in the right-click menu can also be found in the Edit menu (Figure 14).

Discovery Park



omm

NEEShub.org — Getting started with inDEED

File Edit View Plot

[

| Name | Type

&gl PPT-Drains

g8 PPT-Untreated
PPT-UB pressu

PPT-U7 pressu
PPT-U11 pressu
PPT-U12 pressu
PPT-U14 pressu
PPT-U15 pressu
PPT-UB pressu
PPT-U1 pressu
PPT-U2 pressu
PPT-U4 pressu

PPT-US pressu

B¢ PPT-Tubes
@-g8® ACCDrains

4 i

Find sensors

amaE

bt Plot

Figure 9: Selecting an instrument from the instrument list
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4.0 Creating Plots

Once you have selected instruments, you can begin making plots. The “Plot” menu contains separate
plotting options for acceleration, displacement, and pressure (Figure 14). Choose the plot type
appropriate for your selected instruments (Figure 15). You can create multiple plots; each one will
appear in a new tab. If you try to create a plot that is not appropriate to the type of instruments you
have selected, the plot will be empty.

Clicking the “Plot” button at the bottom of the left-side panel will create a plot of the same type as the
last plot that was created. If you have not yet created a plot, the “Plot” button will create an
Acceleration/Sample # plot. If you do not have any acceleration instruments selected, this plot will be
empty.

The “New Template” and “Plot Selected Sensors” options are not currently functional, but will be in
future versions.
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Figure 14: The "Plot" menu
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5.0 Editing Plots
5.1 The Sidebar

The sidebar (Figure 16) contains options for editing the plots you have created. You can hide or show a
selected instrument, raise an instrument (moves it back), lower an instrument (brings it to the front),
rename the instrument, and recolor the plot. If you select two instruments, you can find the difference
or the average of those two instruments. If you select more than two instruments, you can find the
average of those instruments, but not the difference. You can recolor multiple instruments at once. You
can delete the average and difference plots by highlighting them and selecting delete.

In the panel next to the legend are three buttons and four tabs. The top button resets the zoom level.
You can zoom in on parts of the plot by left clicking on the plot window, creating a zoom box, and left
clicking again to finalize the shape of the zoom box (Figure 17). You can also reset the zoom level by
right-clicking in the plot window. If you have zoomed several times, it will back you up by one zoom level
for each right-click.

The second button in the sidebar allows you to download the plot data. There are two options, one to
download the data as comma-separated values and one to download the data as an image. The first
option is not currently functional. The second option opens an image save dialog box with several
options that you can customize (Figure 18). Depending on the file format that you have chosen, you may
need to rename the file with the appropriate file extension (*.png). Some of the file formats are not
currently functional and for those formats, clicking the save button will not produce a save dialog box.
The third button in the sidebar inverts the graph axes; the x-axis becomes the y-axis and vice versa.

Below the three buttons are four tabs. The first tab opens and closes the sidebar while the other three
tabs are not currently functional.
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Figure 17: Zooming in on a selection
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Figure 18: Downloading data as image file

PURDUE UNIVERSITY
-

Discavery Park



h

NEES

comm

NEEShub.org — Getting started with inDEED

5.2 The Axes

Axis information can be edited through a dialog box that appears when you right click on the axis (Figure
19). You can change the axis label, maximum, minimum, number format, and scale type (linear or
logarithmic).
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Figure 19: Axis options
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