NEES.org will be intermittently unavailable Saturday, January 3, for scheduled maintenance. All tool sessions will be expired. We apologize for any inconvenience that may occur.

Support

Support Options

Submit a Support Ticket

 

inDEED - Editing a Mapping File (*.ind File) from within inDEED

by Rachelle Howell, George A. Howlett


When you launch inDEED outside of the Project Warehouse, it becomes possible to edit your inDEED mapping file (*.ind file) from within the inDEED tool. This is particularly useful if you are using the inDEED tool to verify your mapping and you find something that you want to change. The functionality described in this tutorial is disabled when inDEED is launched from within the Project Warehouse.

Launch inDEED

Launch inDEED outside of the Project Warehouse and load your data file (see this tutorial if you need help with this step). The mapping file has to exist outside of the Project Warehouse in order for it to be edited in the manner described in this tutorial. If you load a data file from the Project Warehouse, the inDEED tool will automatically load the mapping from the Project Warehouse as well, and this mapping cannot be edited through inDEED. You can manually load a mapping from your Home Directory (File > Open Author File).

Enter Edit Mode

Enter edit mode via the Edit > Edit Author File menu option. An “Author” file is a file created by the Specimen Authoring Tool, otherwise known as a mapping file or *.ind file.

Edit1.jpg



This will bring up a window inside of your inDEED tool session that looks like the Specimen Authoring Tool. You can now edit the mapping. Be sure to save the file when you are done.

Edit2.jpg



Viewing your changes

The inDEED tool has already loaded your data file using the original mapping. Your changes to the mapping file will not be visible unless you reload your data file. To reload your data file, first clear the data (File > Clear), and then reopen the file (File > Open Data File).

Created on , Last modified on