NEEShub services are beginning to be phased out. Please begin using DesignSafe ( Please submit a support ticket ( if you need any assistance.


Support Options

Submit a Support Ticket


Questions and Answers

0 Like

Daniel McCrum

OpenFresco 3D Model Query

I am currently running ‘soft’ real-time hybrid tests on a cantilever column similar to the local Portal Frame example in the OpenFresco 2.6 examples. The system is an MTS system comprising of Simulink Host PC, xPC Target PC, MTS 493 Real-time Controller, STS Controller PC and a 150kN MTS high speed actuator. I have a couple of queries as follows:

Query 1: When I run a simulation in 3D in OpenFresco, the reaction at the base of the experimental element is zero in all directions. The experimental element is a steel cantilever column. The initial stiffness matrix I am using for the experimental beam element is a 6×6 matrix for a fixed-pinned element. I tried changing the node numbers to see if the orientation was incorrect and I also tried changing the stiffness matrix to fixed-fixed and the result remained the same. The period of the structure changed as would be expected when the connections were changed to fixed-fixed. I was successful in running a 3D model and the reaction at the base node of experimental element as would be expected, even though the simulation gave no reaction. Is this a possible bug?

Query 2: After a number of days running 3D ‘soft’ real-time hybrid tests, without making any changes, the test stopped running. I ran models of previous tests that worked in 3D, but no scramnet command displacement was being sent to the STS Controller PC. The digital readouts for scramnet command were zero. I then ran 2D hybrid tests with success indicating the communication was working, but then could not run 3D tests. I can not explain this. Hopefully it is just a local issue.

If anyone has encountered these issues before, I would be grateful for your help.

Many thanks


Report abuse

2 Responses

  1. 0 Like 0 Dislike

    Frank McKenna

    Query 1: The fact that the model seems to be running correctly suggests one of the following: 1) you are looking for the reaction at a node that is not constrained. 2) the recorder command is incorrect. 3) a bug. what version of OpenSees and OpenFresco are you running?

    I would need to see the script to help more with this. you can email it to me if you are still having problems.

    Query 2: Are you saying that the 3D test stopped working or wa never working due to the scramnet command displacement always being 0?

    Reply Report abuse

    Please login to answer the question.

  2. 0 Like 0 Dislike

    Dawn Weisman

    Daniel – We are doing some investigation to determine how best to answer your questions.

    Dawn Weisman NEEScomm Director of IT

    Reply Report abuse

    Please login to answer the question.